Vine Linux バグトラッキングシステム

課題の詳細を表示 コメントにジャンプ ] 課題の履歴 ] 印刷 ]
IDプロジェクトカテゴリ登録日最終更新
0003063VineSeed1 バグ2016-12-11 21:002016-12-11 21:49
報告者Takemikaduchi 
担当者ara_t 
優先度再現性毎回 
状態担当者決定解決状況不明 
概要0003063: Vine6 -> VineSeed に dist-upgrade すると ghc-bootstrap がインストールされてしまう
説明以前、本事象が起きて修正していただいたのですが、再発してます。
対処願います。

$ apt-cache whatprovides "libffi.so.6()(64bit)"
<libffi.so.6()(64bit)>
  libffi-3.0.13-1vl7
    Provides: <libffi.so.6()(64bit)>
  ghc-bootstrap-7.10.3-1vl7
    Provides: <libffi.so.6()(64bit)>
再現方法Vine6 から VineSeed に dist-upgrade すると起こる。
タグ設定されていません。
archx86, x86_64
パッケージghc-bootstrap-7.10.3-1vl7
添付ファイル

- 関連

-  コメント
(0010037)
ara_t (開発者)
2016-12-11 21:48

ghcでは--with-system-libffiオプションを使用できるのですが、
ghc-bootstrapパッケージでダウンロードして使用するファイルには
--with-system-libffiオプションが用意されておらず
含まれているlibffiを使用してしまうのが原因でした。
(以前と同じ原因です)

解決方法が見つかるまで空のパッケージをアップロードしておきます。
今回の件は解決されると思います。

※ghcそのものをリビルドする以外には問題は生じないはずです。

- 課題の履歴
変更日 ユーザー名 項目 変更内容
2016-12-11 21:00 Takemikaduchi 新規課題
2016-12-11 21:48 ara_t コメント追加: 0010037
2016-12-11 21:49 ara_t 担当者 => ara_t
2016-12-11 21:49 ara_t 状態 新規 => 担当者決定


Copyright © 2000 - 2017 MantisBT Team
Copyright © 2012 - 2017 Project Vine
Powered by Mantis Bugtracker