Vine Linux バグトラッキングシステム

課題の詳細を表示 コメントにジャンプ ] 課題の履歴 ] 印刷 ]
IDプロジェクトカテゴリ登録日最終更新
0003117VineSeed1 バグ2018-12-20 02:502018-12-20 18:35
報告者shirow_higa 
担当者 
優先度再現性毎回 
状態新規解決状況不明 
概要0003117: [Seed] ffmpeg 4.1 で、libvpx 1.7.0を使用するとABIエラーが出る
説明新しいffmpegを自ビルドで使っているのですが、
libvpx 1.7.0を使用すると以下のエラーが出て使えません。

[libvpx @ 0x80cec40] Failed to initialize encoder: ABI version mismatch

ffmpeg側が対応してないと思いますので、対応するまで
libvpxのバージョンを、1.6.1あたりに下げられないでしょうか?
タグ設定されていません。
archx86
パッケージlibvpx-1.7.0-1vl7
添付ファイル

- 関連

-  コメント
(0010249)
tomop (管理者)
2018-12-20 03:05

 libvpxが複数入って(rpmからインストールしたものと自前でビルドしたもの、等)いたりしませんか?
(0010250)
shirow_higa (報告者)
2018-12-20 18:35

ご返信ありがとうございます。


おっしゃる通り、以前に自ビルドしたゴミが残っておりました。

/usr/local/lib/lib/vpx.a
/usr/local/lib/pkgconfig/vpx.pc
/usr/local/include/vpx/*

以上を削除し、ffmpegを再ビルドしたところ無事VP8、VP9共に使用する事が出来ました。

バグではない所、お手数をお掛けしました。

ありがとうございました。

- 課題の履歴
変更日 ユーザー名 項目 変更内容
2018-12-20 02:50 shirow_higa 新規課題
2018-12-20 03:05 tomop コメント追加: 0010249
2018-12-20 18:35 shirow_higa コメント追加: 0010250


Copyright © 2000 - 2019 MantisBT Team
Copyright © 2012 - 2019 Project Vine
Powered by Mantis Bugtracker