Vine Linux バグトラッキングシステム

課題の詳細を表示 コメントにジャンプ ] 課題の履歴 ] 印刷 ]
IDプロジェクトカテゴリ登録日最終更新
0003105requests1 要望2017-12-24 13:482017-12-26 22:17
報告者hl.hex 
担当者tomop 
優先度再現性未試験 
状態テスト待ち解決状況不明 
バージョンVineSeed 
修正予定バージョン修正済バージョン 
概要0003105: nodejs の更新願
説明現行のseed上では nodejs-0.10.26-2vl7.i686 ですが
stableが node-v9.3.0
LTSが、node-v8.9.3 となっており、
基本的なパッケージの管理などに支障が出始めていますので
せめてLTSにupdateをお願い致します。
タグ設定されていません。
添付ファイル

- 関連

-  コメント
(0010187)
tomop (管理者)
2017-12-25 00:26

 buildが非常に難解でこれ以上時間が確保できないため、nodebrewのご利用をおすすめします。

https://github.com/hokaccha/nodebrew [^]
https://qiita.com/sinmetal/items/154e81823f386279b33c [^]
(0010188)
hl.hex (報告者)
2017-12-25 16:36

今時の主要なツールの類いなので、ディストリ側でメンテされないのは大変残念ですが、
致し方在りません。現行の物はEOLを迎えていますので、リポジトリからの削除を視野に
入れた方が良いと思います。

https://github.com/nodejs/Release [^]

野良ビルドの方向で試行してみようと思います。
この案件は完了として下さい。
(0010189)
tomop (管理者)
2017-12-26 22:17

 v8単独でのbuildで挫折していましたが、node.js同梱のv8はオリジナルのままではなく、同梱のものを利用する方がよさそうでしたのでそのように変更し8.9.3に更新しました。

 が、以下の理由によりnodebrewを使うことをおすすめします。

- 任意のバージョンを複数インストールし、切り替えての利用が可能。
- node.js関連ファイルが全てホームディレクトリに入るため、システムディレクトリを汚さない。

- 課題の履歴
変更日 ユーザー名 項目 変更内容
2017-12-24 13:48 hl.hex 新規課題
2017-12-25 00:26 tomop コメント追加: 0010187
2017-12-25 00:26 tomop 担当者 => tomop
2017-12-25 00:26 tomop 状態 新規 => 内容確認済
2017-12-25 16:36 hl.hex コメント追加: 0010188
2017-12-26 22:17 tomop コメント追加: 0010189
2017-12-26 22:17 tomop 状態 内容確認済 => テスト待ち


Copyright © 2000 - 2018 MantisBT Team
Copyright © 2012 - 2018 Project Vine
Powered by Mantis Bugtracker