Vine Linux バグトラッキングシステム

課題の詳細を表示 コメントにジャンプ ] 課題の履歴 ] 印刷 ]
IDプロジェクトカテゴリ登録日最終更新
0002463requests1 要望2012-10-15 02:272012-10-15 02:27
報告者R MIyazaki 
担当者 
優先度再現性毎回 
状態新規解決状況不明 
バージョン6.1 
修正予定バージョン修正済バージョン 
概要0002463: synapticとapt-getでバージョン固定の一貫性を持たせて欲しい
説明前置きとして度々synapticのことで投稿してしまい少々申し訳無く思ってます。

aptにおいてパッケージのバージョン固定をしたい時は/etc/apt/preferencesに例えば
下のように記述すれば良くこうするとsynapticではパッケージの状態を示す□マーク
に鍵の絵は付かないものの動作としてはバージョンが固定されたものとして振る舞う
ようです(synapticが)。
記述例

[root@localhost apt]# cat /etc/apt/preferences
Package: install-assist-flash-plugin
Pin: version 11.1.102.63-1vl6
Pin-Priority: 1001

Package: flash-plugin
Pin: version 11.1.102.63-release
Pin-Priority: 1001

一方synapticのバージョン固定を使って固定した場合、□に鍵の絵が付きsynaptic
においてはバージョンが固定されたものとして動作しますがapt-get update ->
apt-get dist-upgradeするとsynapticでバージョン固定したパッケージもアップデート
されてしまいます。
自分としてはsynapticはaptのGUIフロントエンドであると認識しているのでこのような
動作はアップデートツールとして整合性が無いもののように感じます。
synapticとaptコマンドで振る舞いに一貫性を持たせて頂きたく思います。

宮崎隆一
再現方法複数バージョンがインストール可能になっているパッケージを/etc/apt/preferences
ファイルを編集することによりバージョン固定してapt,synapticでの振る舞いを見た後
/etc/apt/preferencesを空のファイルに戻し同一のパッケージをsynapticからバージョン
強制->バージョン固定して同様にapt,synapticでの振る舞いの違いを検証する。
タグ設定されていません。
添付ファイル

- 関連

-  コメント
この課題に対するコメントはありません。

- 課題の履歴
変更日 ユーザー名 項目 変更内容
2012-10-15 02:27 R MIyazaki 新規課題


Copyright © 2000 - 2019 MantisBT Team
Copyright © 2012 - 2019 Project Vine
Powered by Mantis Bugtracker