Vine Linux バグトラッキングシステム

リビジョンを表示: 課題#1202 全リビジョン ] 課題に戻る ]
概要 0001202: compat32-libdrm がインストールできない
リビジョン iwamoto による 2012-10-11 01:31
説明 apt-get install compat32-libdrm
を実行すると、

 パッケージリストを読みこんでいます... 完了
 依存情報ツリーを作成しています... 完了
 'compat32-libdrm' として compat32-libdrm.32bit を選択しました
 いくつかのパッケージをインストールすることができません。おそらく、
 整合性のとれない状況を要求したか、(必要なパッケージがまだそろって
 いなかったり、まだIncomingから移動されていない)不安定なディストリ
 ビューションを使用していないでしょうか。
 
 単純な操作だけを行った時に、パッケージがインストール
 できない場合は、バグリポートしてください。
 以下の情報がこの問題を解決するために役立つかもしれません:
 
 以下のパッケージは解決できない依存関係を持っています:
   compat32-libdrm.32bit: 依存: libpciaccess.so.0 それをインストールすることができません
 E: 壊れたパッケージです

これがインストール出来ないと、compat32-mesa-libGL
がインストール出来ないので、
install-assist-AdobeReader_jpn
をインストールするのに必要とされてしまう?
compat32-mesa-libGLU パッケージが
xorg-x11-drv-nvidia-32 の libGL.so.1 で依存関係を解決しようとして、
不要なドライバーがインストールされてしまいます。

xorg-x11-drv-nvidia がインストールされていると、
モジュールextensions のパスが
/usr/lib64/xorg/modules/extensions/nvidia
の方が先になるっぽいので、
/usr/lib64/xorg/modules/extensions/nvidia/libglx.so
がロードされてしまって
glxgears とかが動作しなくなります。
リビジョン anonymous による 2011-08-16 12:56
説明 apt-get install compat32-libdrm
を実行すると、

 パッケージリストを読みこんでいます... 完了
 依存情報ツリーを作成しています... 完了
 'compat32-libdrm' として compat32-libdrm.32bit を選択しました
 いくつかのパッケージをインストールすることができません。おそらく、
 整合性のとれない状況を要求したか、(必要なパッケージがまだそろって
 いなかったり、まだIncomingから移動されていない)不安定なディストリ
 ビューションを使用していないでしょうか。
 
 単純な操作だけを行った時に、パッケージがインストール
 できない場合は、バグリポートしてください。
 以下の情報がこの問題を解決するために役立つかもしれません:
 
 以下のパッケージは解決できない依存関係を持っています:
   compat32-libdrm.32bit: 依存: libpciaccess.so.0 それをインストールすることができません
 E: 壊れたパッケージです

これがインストール出来ないと、compat32-mesa-libGL
がインストール出来ないので、
install-assist-AdobeReader_jpn
をインストールするのに必要とされてしまう?
compat32-mesa-libGLU パッケージが
xorg-x11-drv-nvidia-32 の libGL.so.1 で依存関係を解決しようとして、
不要なドライバーがインストールされてしまいます。

xorg-x11-drv-nvidia がインストールされていると、
モジュールextensions のパスが
/usr/lib64/xorg/modules/extensions/nvidia
の方が先になるっぽいので、
/usr/lib64/xorg/modules/extensions/nvidia/libglx.so
がロードされてしまって
glxgears とかが動作しなくなります。


Copyright © 2000 - 2019 MantisBT Team
Copyright © 2012 - 2019 Project Vine
Powered by Mantis Bugtracker